Welcome to Our Community

Some features disabled for guests. Register Today.

Z probe not workin

Discussion in 'Control Software' started by Rob Atha, Oct 10, 2018.

  1. Rob Atha

    Rob Atha Well-Known
    Builder

    Joined:
    Aug 19, 2018
    Messages:
    7
    Likes Received:
    2
    :(hi all

    I’m after a bit of help. I’ve made a combined edge probe and touch plate for my cnc. Connected the positive to the plate and negative to my spindle. The positive is connected to port a5 on my Arduino Uno and ground to the ground pin. But no matter what I do, I can’t seam to get the probe to work, is there something I’ve missed as apart from how to use the probe, I can’t seam to find any tutorials on how to set it up.

    I’ve checked the continuity on the wiring and all if fine, but just won’t work then the tool touches the plate

    Hope someone can help with this:(:(:(:banghead:
     
  2. DarkPenguin

    DarkPenguin Journeyman
    Builder

    Joined:
    Sep 16, 2017
    Messages:
    40
    Likes Received:
    3
    Doesn't $H run the homing cycle?
     
  3. Rob Atha

    Rob Atha Well-Known
    Builder

    Joined:
    Aug 19, 2018
    Messages:
    7
    Likes Received:
    2
    I’ve managed to sort this now, it appears that the internal pull up resistor on my uno isn’t strong enough for my build
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice