Welcome to Our Community

Some features disabled for guests. Register Today.

Universal G Code

Discussion in 'General Talk' started by Nils, Dec 27, 2015.

  1. Nils

    Nils New
    Builder

    Joined:
    Sep 3, 2014
    Messages:
    3
    Likes Received:
    0
    I'm having trouble finding and loading the universal g code sender onto my laptop. It took me forever to get the grbl controller on my laptop, only to find out that it doesn't work well with the xpro.
    I'm at the door way of getting my CNC fully operational but need some help with the universal gcode sender, how to install it on my laptop and where to find it.

    Thanks

    Dashell1
     
  2. David the swarfer

    David the swarfer OpenBuilds Team
    Staff Member Moderator Builder

    Joined:
    Aug 6, 2013
    Messages:
    795
    Likes Received:
    362
    well, how about Googling for the web site?
    the first link I see is for
    winder/Universal-G-Code-Sender ┬Ě GitHub
    and you want the 1.0.9 build linked about half way down.
    the install instructions say:
    what that means is
    if you are on windows, double click the .jar file
    if you are on Mac or Linux, double click the start.sh file

    and of course you need Java installed as well, it probably is already, but if it is not, then
    java.com: Java + You
     
    Mark Carew likes this.
  3. Steve Fox

    Steve Fox Veteran
    Builder

    Joined:
    Feb 22, 2015
    Messages:
    129
    Likes Received:
    20
    I'm not sure what's going on, but I couldn't get it to run either.
    I had to go down to the nightly builds section and download the Classic GUI build.
    Once you get it unzipped, run the .bat file.
    That should work.

    BTW, I have a version about three months old on three laptops and get different results on each one.
    One works fine, one doesn't work at all and on the other, the visualizer doesn't work.
    I haven't spent any time trying to troubleshoot the problem, I just use the laptop that works.
     
  4. dcarlisle

    dcarlisle Well-Known
    Builder

    Joined:
    Jan 24, 2015
    Messages:
    29
    Likes Received:
    1
    just a little note not sure if it will help but i have been using universal gcode sender with out problem went to use it today and when i tried to open it it wouldn't open
    downloaded and reinstaled it still nothing did some digging
    I updated my java on my computer since last time i used it well did a check and the update from java online did not work seems to be having a problem downladed the offline version and now i have java and gcode sender is working again just something to check make sure your java is working correctly
     
  5. Steve Fox

    Steve Fox Veteran
    Builder

    Joined:
    Feb 22, 2015
    Messages:
    129
    Likes Received:
    20
    My problem seems to have started when I uninstalled all of the old versions of JAVA a couple of days ago.
    I reinstalled the newest version today and the latest version of UGS still doesn't work.
     
  6. dcarlisle

    dcarlisle Well-Known
    Builder

    Joined:
    Jan 24, 2015
    Messages:
    29
    Likes Received:
    1
    that's what happened to mine
    I updated java and uninstalled all old versions thought I was good till I went to the java site and ran a check on the version of java on my computer and it was screwed up
    so I downloaded the offline update of java and reinstalled it and now it is working
    I'm am in no way a expert on any of this still getting my feet wet and working threw issues as I go
    maybe someone else can give more info I figured I post what I did maybe it'll help someone in the future
     
  7. Steve Fox

    Steve Fox Veteran
    Builder

    Joined:
    Feb 22, 2015
    Messages:
    129
    Likes Received:
    20
    Just tried that and it didn't work either.
    I installed the 64bit version and couldn't gt that to verify, so I uninstalled that and installed the 32bit version.
    That verified, but the current version of UGS still doesn't work.

    This is my desktop, so I don't use it to drive my Ox anyway, but it would be nice to figure out what the problem is.
    I'm no expert either, but I do know my way around Windows. It doesn't help sometimes.

    btw Dashelli, if You go into the release_files directory, there is a batch file to run UGS so you don't have to type in the command line format.
     
  8. Nils

    Nils New
    Builder

    Joined:
    Sep 3, 2014
    Messages:
    3
    Likes Received:
    0
     
  9. Nils

    Nils New
    Builder

    Joined:
    Sep 3, 2014
    Messages:
    3
    Likes Received:
    0
    I couldn't open the .jar file, nothing would open it. I did finally get it to work via the batch file, so I'm happy with that. Now it's on to calibrating the machine.
     

Share This Page