Welcome to Our Community

Some features disabled for guests. Register Today.

Stepper problem: Ramps 1.4 + Marlin + Nema 17

Discussion in 'Motors' started by elib, Nov 30, 2016.

  1. elib

    elib New
    Builder

    Joined:
    Nov 28, 2016
    Messages:
    6
    Likes Received:
    0
    Hello,

    I'm currently working on a new 3D printer based on this OpenBuilds project (Voxel OX - Extendable 3D Printer and CNC Platform)

    What I'm using:
    - Ramps 1.4
    - Nema 17 stepper
    - 12v 19amp power supply

    The problem is that the steppers don't seem to work correctly. When I test them, some only works when moving with 0.1mm steps and stop moving when moving by 10mm.

    I'have also noticed that the noise coming from the stepper is a bit loud.

    I don't know what to test or where to go to fix my problem. Could you please give me some advices?

    -> Extruder doesn't move at all
    -> Some stepper look like being more precise and constant
    -> I can provide you video if needed.
    -> I have already play with the potentiometer on the Polulu

    Thanks for your answer!

    Edouard
     
  2. Anthony Bolgar

    Builder

    Joined:
    Jan 14, 2016
    Messages:
    251
    Likes Received:
    137
    Please post the video.
     
  3. elib

    elib New
    Builder

    Joined:
    Nov 28, 2016
    Messages:
    6
    Likes Received:
    0
    Hello,

    Here are 3 videos presenting the 3 axis. I'm sorry for the quality and exposure. It's maximum light in my desk and my smartphone is very ****** (I'll get a new one soon and could provide you then new videos if needed)
    But the main problem is presenting: the noise and the way parts move.



     
  4. Krashlnd

    Krashlnd Journeyman
    Builder

    Joined:
    Sep 6, 2016
    Messages:
    31
    Likes Received:
    7
    To me it sounds like your steps are set wrong. Tell any of the axis' to move 10 mm (at a slow rate as not to miss a step) and measure how far it moved. If you need help setting the steps in the marlin firmware I can help you. Also adjust the vref of each axis.
    Steve
     

Share This Page