Welcome to Our Community

Some features disabled for guests. Register Today.

[SOLVED] An unknown error occured:TypeError: Cannot read properly "color" of undefined

Discussion in 'OpenBuilds Bug Report' started by Mightymike, Sep 17, 2020.

  1. Mightymike

    Builder

    Joined:
    Sep 17, 2020
    Messages:
    13
    Likes Received:
    4
    Hello to all!

    i'm new here, i've just acuired my cnc from a friend who built it for me.
    He showed to me how to open the svg files, but when we open a dxf i get this error:
    An unknown error occured:TypeError: Cannot read properly "color" of undefined

    Does anyone had the same issue?

    thank you in advance!
     
  2. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Project Maker Builder Resident Builder

    Joined:
    Mar 1, 2017
    Messages:
    8,381
    Likes Received:
    2,759
  3. Mightymike

    Builder

    Joined:
    Sep 17, 2020
    Messages:
    13
    Likes Received:
    4
    thank you for your reply, but in autocad 2020 there is no save as DXF-R14.
    Is there another way/program to convert it?

    thank you again in advance
     
  4. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Project Maker Builder Resident Builder

    Joined:
    Mar 1, 2017
    Messages:
    8,381
    Likes Received:
    2,759
    You can use LibreCAD as an in-between converter
     
  5. Mightymike

    Builder

    Joined:
    Sep 17, 2020
    Messages:
    13
    Likes Received:
    4
    Peter Van Der Walt likes this.
  6. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Project Maker Builder Resident Builder

    Joined:
    Mar 1, 2017
    Messages:
    8,381
    Likes Received:
    2,759
    Will check when I am near a computer
     
  7. Mightymike

    Builder

    Joined:
    Sep 17, 2020
    Messages:
    13
    Likes Received:
    4
    no worries. thank you for your time. i will wait.

    also, is it possible that the program need the lines in the dxf file to be bold?

    thank you
     
  8. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Project Maker Builder Resident Builder

    Joined:
    Mar 1, 2017
    Messages:
    8,381
    Likes Received:
    2,759
    No, as per the link above, it just needs to be polylines.

    I am typing this off my phone, but as the error relates to color, did you have anything odd with colors? Select all and change it to a color in LibreCAD (say white)

    There also seems to be missing lines on the bottom right (that leg is open. For cnc work you have to have closed vectors)

    Screenshot_2020-09-19-07-19-26-857_com.elmer.SchemataCAD_viewer.jpg

    And delete the Information frame, that is for print reference (frame around drawing), details bottom right etc.
    Just leave the Part you want

    You don't want the CAM to have to deal with all the extra vectors that it has no need for / cannot understand anyway
     
    #8 Peter Van Der Walt, Sep 19, 2020
    Last edited: Sep 19, 2020
  9. Mightymike

    Builder

    Joined:
    Sep 17, 2020
    Messages:
    13
    Likes Received:
    4
    sorry for the delay.

    i want to thank you for you solution. i changed the color from grey to black, i deleted the extra information around the drawing and used the programs as you said.

    thank you so much.
     
    sharmstr and Peter Van Der Walt like this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice