Welcome to Our Community

Some features disabled for guests. Register Today.

Software Tab ???

Discussion in 'General Talk' started by joe williams, Sep 2, 2018.

  1. joe williams

    joe williams Veteran
    Builder

    Joined:
    Nov 9, 2015
    Messages:
    70
    Likes Received:
    46
    Hey....what's up with that new menu tab ? :D

    new-menu-tab.png
     
    sharmstr likes this.
  2. joe williams

    joe williams Veteran
    Builder

    Joined:
    Nov 9, 2015
    Messages:
    70
    Likes Received:
    46
    Is something happening on September 4th ?.....what are we going to do until Tuesday ?
     
  3. David the swarfer

    David the swarfer OpenBuilds Team
    Staff Member Moderator Builder

    Joined:
    Aug 6, 2013
    Messages:
    985
    Likes Received:
    448
    @Mark Carew : on the cam setup it shows the 'end gcode' as below
    camerr1.png

    but that is incorrect
    it should be
    G0 X0 Y0 ; the Y is missing from your code

    AND!!!!
    I cannot type a Y there to fix it. many other letters can be typed, but not Y
     
    joe williams likes this.
  4. joe williams

    joe williams Veteran
    Builder

    Joined:
    Nov 9, 2015
    Messages:
    70
    Likes Received:
    46
    @Mark Carew, @David the swarfer, I'm hoping the Linux driver download works some time today....I mean "Y" not? All will be revealed today, right?
     
  5. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    328
    Likes Received:
    249
    #5 Peter Van Der Walt, Sep 4, 2018
    Last edited: Sep 4, 2018
    David the swarfer likes this.
  6. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    328
    Likes Received:
    249
    Checking from my side, the Linux DL works (and installs fine on my Ubuntu box) - can you elaborate on any issues? (Ctrl+shift+i -> devtools console always gives some clues) or use the alternate download at OpenBuilds/SW-Machine-Drivers (download.openbuilds.com just tries to present it a little prettier - but Github releases is the backend)
     
  7. joe williams

    joe williams Veteran
    Builder

    Joined:
    Nov 9, 2015
    Messages:
    70
    Likes Received:
    46
    @Peter Van Der Walt, all the green buttons show just a placeholder link: [ Download OpenBuilds Software]

    I'm using:
    • Ubuntu 18.04
    • Google Chrome: Version 68.0.3440.106 (Official Build) (64-bit)
    • Acer i7 laptop
    I'll try that alternate download link later, thanx!
     
  8. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    328
    Likes Received:
    249
    The buttons has a JS onclick event (So the Placeholder is valid HTML) - that executes an ajax getJSON to Github Releases to grab you the Latest exe/dmg/deb/appimage etc as appropriate - using ajax instead of hardcoded links means I dont need to keep updating the link :) and spend more time making cool features (As each Github Release has the Tag in the URL)

    (Checkout OpenBuilds/download if you want to know what it does under the bonnet)
     
  9. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    328
    Likes Received:
    249
    That said - I think I see bug (; Gimme 10 and i'll fix it for you!

    [edit: fixed :) ]
     
    #9 Peter Van Der Walt, Sep 4, 2018
    Last edited: Sep 4, 2018
    Mark Carew and David the swarfer like this.
  10. GrayUK

    GrayUK Openbuilds Team Elder
    Staff Member Moderator Builder

    Joined:
    May 5, 2014
    Messages:
    1,430
    Likes Received:
    461
    Well...... That went straight over my head. :D:p
     
    Peter Van Der Walt likes this.
  11. joe williams

    joe williams Veteran
    Builder

    Joined:
    Nov 9, 2015
    Messages:
    70
    Likes Received:
    46
    @GrayUK , back when I was still doing some web development, we were just beginning to use some ajax routines to make life simpler. Now when I think about digging into anything web development-like, my eyes roll back in my head and i start to drool :rolleyes:

    @Peter Van Der Walt , still not working for me, but the problem is probably on my end:
    Screenshot from 2018-09-04 08-58-14.png
    been having some Java issues since upgrading to 18.04. I got the linux driver at github, installed the deb and the browser based CAM finds the driver. The App itself doesn't open. I get the above error instead. I guess I'll fiddle with it all later! Thanks!
     
  12. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    328
    Likes Received:
    249
    :) Always a chance its our side :) - especially the Linux side (not so many users - so gets a bit less testing) - so don't rule that out yet :)
    I picked up you knew a little though when I saw you checking the placeholder/href )

    Quick question: Is this the DEB or the AppImage one?

    (I'll download 18.04 tonight - been putting off updating) and see if I can replicate - the AppImage shouldnt be running in /opt - and maybe just maybe the .deb installer is doing something odd)
    If you are on the .deb, try the AppImage too - it's kinda cool AppImage
     
  13. joe williams

    joe williams Veteran
    Builder

    Joined:
    Nov 9, 2015
    Messages:
    70
    Likes Received:
    46
    so now everything is magically working, download buttons and the app. Downloaded the deb a second time, installed it and it works (there was some kind of error screen, but it continued on to load and run) Jogging my test setup now!
     
  14. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    328
    Likes Received:
    249
    :) Sweet! I fixed the download button bug (stupid mistake, had a little code in there (windows only) from before we added the mac/linux versions hehe) so I'll say that less likely magic (;
    But the other one, I didnt do a fix.

    However the error was because it was started with a parameter, which wasnt a file.

    (You can run './openbuildsmachinedriver file.gcode' and it'll open the file. The error looked like it was getting a parameter, but said parameter wasnt a file. Maybe ubuntu was adding something onto the end of the command for some odd reason. Still, it needs some extra coding to handle that without throwing an error :) - the 1.8gb Ubunntu 18.04 ISO is in my download queue - will see if I can replicate and then fix
     
    Mark Carew likes this.
  15. joe williams

    joe williams Veteran
    Builder

    Joined:
    Nov 9, 2015
    Messages:
    70
    Likes Received:
    46
    :thumbsup:
     
    #15 joe williams, Sep 4, 2018
    Last edited: Sep 4, 2018
  16. HC.Carbo

    HC.Carbo Veteran
    Builder

    Joined:
    Jan 7, 2018
    Messages:
    95
    Likes Received:
    96
    mmm, (maybe it's my old sys. win7 / google chrome)

    put a circle in > move it...& get Pinokkio on your screen :)


    [​IMG]
     

    Attached Files:

  17. HC.Carbo

    HC.Carbo Veteran
    Builder

    Joined:
    Jan 7, 2018
    Messages:
    95
    Likes Received:
    96
    works fine with imported .svg files > export to mach4 :)
     
  18. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    328
    Likes Received:
    249
    Nope, known bug - but super rare :) this would be the third instance I know of, in 7 months)

    Workaround:
    move (it messes up the first point)
    Undo, (ctrl+Z)
    Now move again, and it works. (Well for the two other times I've found this)

    Do drop me the test file, from the other two I couldnt find why those drawings had issues with their first vertex jumping differently (With only two files, its hard to pickup a pattern to debug - so one more may just help) - also include which CAD it came from :)

    I actually want to rewrite DragMove entirely (Todo: DragMove: Enhance to support selected objects as well · Issue #2 · OpenBuilds/cam ) to also make it more useful, that might just incidentally solve it - but would be better to find what the issue is, and properly fix it.
     
    David the swarfer likes this.
  19. HC.Carbo

    HC.Carbo Veteran
    Builder

    Joined:
    Jan 7, 2018
    Messages:
    95
    Likes Received:
    96
    lol: now i have pacman on my screen. :)
    This happens only when use the build in circle tool, not with a imported svg.
     
  20. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    328
    Likes Received:
    249
    Aha! Will check it out! :)
     
  21. joe williams

    joe williams Veteran
    Builder

    Joined:
    Nov 9, 2015
    Messages:
    70
    Likes Received:
    46
  22. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    328
    Likes Received:
    249
    HC.Carbo likes this.
  23. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    328
    Likes Received:
    249
  24. HC.Carbo

    HC.Carbo Veteran
    Builder

    Joined:
    Jan 7, 2018
    Messages:
    95
    Likes Received:
    96

    Attached Files:

    Peter Van Der Walt likes this.
  25. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    328
    Likes Received:
    249
    Yeah I only addressed the Move - the undo is a different little can of worms :) - it's on the todo!

     
  26. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    328
    Likes Received:
    249
    Was fixed today :) - you can test again please and let me know if you find any new issues
     
  27. HC.Carbo

    HC.Carbo Veteran
    Builder

    Joined:
    Jan 7, 2018
    Messages:
    95
    Likes Received:
    96
    jep, seems ok now (y)
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice