Welcome to Our Community

Some features disabled for guests. Register Today.

Problems with tinyg motor 3 slot on Y axis

Discussion in 'General Talk' started by gazingm42, Mar 4, 2017.

  1. gazingm42

    gazingm42 Journeyman
    Builder

    Joined:
    Feb 8, 2017
    Messages:
    52
    Likes Received:
    9
    So I finally got every thing connected on the tinyg. I have motor3 and motor 4 on the y-axis. I set
    $3ma and $4ma to = 1. I can turn the motors flex coupling and every thing turns find by hand.
    But when I connect to universal G code sender and hit the y+/- the motor 4 turns fine. But appears
    to be no movement on the motor 4.

    I disconnect the lead screw on both sides for testing.

    So just the motor is connected to the flex coupling. I up the step to 5 in on the universal gcode sender to
    see the motor rotations better.

    If I click the +/- I see motor 3 move several turns. But motor 4 moves only a degree or 2. So I thought I
    might had a bad motor. So I changed the motors for 3 and 4. But only to find the motor connect to motor
    4 output on ting moves only a few degrees.

    The trim pots are set between 4 and 8. I moved them motor 3 slightly to left or right with no change.

    Any suggestions? Setting?

    Thanks
     
    #1 gazingm42, Mar 4, 2017
    Last edited: Mar 4, 2017
  2. Giarc

    Giarc Master
    Builder

    Joined:
    Jan 24, 2015
    Messages:
    552
    Likes Received:
    259
    I do not know much about Tinyg so I may be wasting your time, but on other control boards (at least the arduino based ones I am familiar with) there is a jumper you have to set to slave two axis together. For example on the cnc shield the axis are labeled X,Y,Z,A and A can be slaved to any of the other 3.
     
  3. gazingm42

    gazingm42 Journeyman
    Builder

    Joined:
    Feb 8, 2017
    Messages:
    52
    Likes Received:
    9
    Problem fixed... I discovered the $3tr=1.25 was the same on $1tr and $2tr. But on $4tr it was 3.60. Changing it to 1.25 and reconnect the leadscrews etc all works.
     
  4. TrishC

    TrishC OpenBuilds Team
    Staff Member Moderator Builder

    Joined:
    Mar 1, 2017
    Messages:
    15
    Likes Received:
    3
    Great. Glad to hear you go it working!
     

Share This Page