Welcome to Our Community

Some features disabled for guests. Register Today.

Need Help Please with cnc drivers

Discussion in 'Tutorials' started by jltcet, Oct 24, 2023.

  1. jltcet

    jltcet Well-Known
    Builder

    Joined:
    Oct 24, 2023
    Messages:
    104
    Likes Received:
    16
    I could really use some help here as Im very GREEN to doing this. I built a cnc router its ready to go but im not sure if I have the motor drivers hooked up correctly ill list what I have .
    D-FLIFE 2pcs DM556 CNC Digital Stepper Motor Driver 2-Phase Stepper Motor Driver 20-50V DC Max 5.6A 128 Subdivision for Nema 23, 24 and Nema 34 Stepper Motor
    DM556 Stepper Motor Driver
    Features:
    DSP Digital Stepper Motor Driver
    Standard Single Pulse Interface
    Provides Energy-Saving Semi-Automatic Current Locking Function
    Semi-Enclosed Housing Can Be Adapted to More Stringent Environment
    High Speed Optocoupler Isolation Signal
    Strong Resistance to High-Frequency Interference
    Built-in Overheat, Over-Current,Over-voltage and Under-voltage Protection
    Can Drive 4,6, 8 Wire Two Phase Stepper Motor
    Control Signal 5-24V Universal, No Series Resistance RequiredApplication
    Suitable for Nema 17, Nema 23 and Nema34 Stepper Motor,2-Phase Hybrid Stepper Motors (Outer Diameter: 42,57,66mm)
    Used for All Kinds of Small and Medium-Sized Automation Equipment and Instruments: Engraving Machine, Marking Machine, Cutting Machine, Laser Typesetting, Plotter, CNC Machine Tools, Automatic Assembly Equipment, etc.Specification:
    Input Voltage: DC 24-50V
    Output Current: 1.0-5.6A, 8 Level Adjustable, 0.5A Resolution
    Drive Method: Bipolar Constant Current PWM Drive
    Pulse Response Frequency: 200kHz(Max)
    Insulation Resistance: >500MΩ
    Insulation Strength: 500V/min
    Dimensions: 118*75.5*34mm / 4.6*3.0*1.3in

    Nema 23 CNC Stepper Motor 3A 178.5oz.in 1.2Nm 57HS56 CNC Stepping Motor DIY CNC Milling Engraving Machine (178.5oz.in-1.2Nm)
    • Specification:1.2Nm(175oz.in) holding torque,Current:3A,Step angle:1.8°,phase:2,Resistance:0.95±10%Ω,inductance:2.8±20%mH
    • Size: Frame Size: 57 x 57mm ,Body Length: 56mm ,Shaft Diameter: 8mm , Shaft Length: 21mm
    • Connection: Red(A+), Green(A-), Yellow(B+), Blue(B-)
    Adriano ono with CNC shield
    My question is I flashed the drivers the other night but only the Z axis would work nothing else Im not sure I have those little micro switches in the correct settings as wiring isn't my best forte. I flashed something called GRBL Longmill was thinking for trying something else any pointers or help would be greatly appreciated I can send any information needed to get me going in the correct direction but though this was a good start


    SaveShare
     

    Attached Files:

  2. Giarc

    Giarc OpenBuilds Team
    Staff Member Moderator Builder Resident Builder

    Joined:
    Jan 24, 2015
    Messages:
    2,945
    Likes Received:
    1,638
    You need GRBL not the longmill version, and you need to read the grbl wiki. It will tell you how to hook everything up and also that your cnc shield has a slightly different pin-out because it has been obsolete since grbl 0.8. It will still work, but you need to make a small wiring change if you want full features.Home
     
    David the swarfer likes this.
  3. jltcet

    jltcet Well-Known
    Builder

    Joined:
    Oct 24, 2023
    Messages:
    104
    Likes Received:
    16

    Thank you for your help Now I have a starting point very much appreciated
     
  4. David the swarfer

    David the swarfer OpenBuilds Team
    Staff Member Moderator Builder Resident Builder

    Joined:
    Aug 6, 2013
    Messages:
    3,303
    Likes Received:
    1,847
    I would flash grbl from openbuildsCONTROL (select blackbox 4x), easiest to do, and will work fine provided you follow the wiring for GRBL1.1
     
  5. jltcet

    jltcet Well-Known
    Builder

    Joined:
    Oct 24, 2023
    Messages:
    104
    Likes Received:
    16
    Yes I was looking at that awhile back but didnt see the MAC download TAB until just now Thank you Ill check it out
     
  6. jltcet

    jltcet Well-Known
    Builder

    Joined:
    Oct 24, 2023
    Messages:
    104
    Likes Received:
    16
    Another question when it ask what machine what should I put I dosent have a DYI setting
     
  7. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Builder Resident Builder

    Joined:
    Mar 1, 2017
    Messages:
    14,251
    Likes Received:
    4,163
    Machine profile in Grbl Settings tab? CUSTOM right at the bottom of the list

    If you mean flashing tool, as David mentioned:


     
  8. jltcet

    jltcet Well-Known
    Builder

    Joined:
    Oct 24, 2023
    Messages:
    104
    Likes Received:
    16
    I believe I found it
     

    Attached Files:

  9. jltcet

    jltcet Well-Known
    Builder

    Joined:
    Oct 24, 2023
    Messages:
    104
    Likes Received:
    16
    Ok so I got it working for the most part. Motors are rough in one direction but not the other, cant figure out why the duel Y works fine traveling in the Y+ but in the Y- One side goes back and the other forward Any word of wisdom would be appreciated
    Thank you,
    Jerry T.
     
  10. Alex Chambers

    Alex Chambers Master
    Moderator Builder

    Joined:
    Nov 1, 2018
    Messages:
    2,713
    Likes Received:
    1,330
    Check the DIR wiring to the stepper driver for the motor that only goes in one direction.

    Alex.
     
    David the swarfer likes this.
  11. jltcet

    jltcet Well-Known
    Builder

    Joined:
    Oct 24, 2023
    Messages:
    104
    Likes Received:
    16
    That didn't do anything everything looks good but LOL must not be o_O Thank you
     
  12. Misterg

    Misterg Journeyman
    Staff Member Moderator Builder Resident Builder

    Joined:
    Aug 27, 2022
    Messages:
    285
    Likes Received:
    224
    Check also the wiring between drives and Y motors. Steppers will run with only one phase connected, but the direction is unpredictable!
     
  13. jltcet

    jltcet Well-Known
    Builder

    Joined:
    Oct 24, 2023
    Messages:
    104
    Likes Received:
    16
    Ok so this morning all I did was retighten some wires double checked the wiring nothing really, and now the Y axis moves in both directions:thumbsup: But in the Y- direction is really really rough. Also noticed that the power supply was set to 230v and not 115v so maybe that had something to do with it but IDK :(. Any Ideas as to why its running so rough and slow in the Y- direction :banghead:. Also want to tank everyone who helped me with this its very appreciated, Thank you.
     
  14. jltcet

    jltcet Well-Known
    Builder

    Joined:
    Oct 24, 2023
    Messages:
    104
    Likes Received:
    16
    So this is whats going on with the Axis
    Y+ runs smoothly
    Y- runs Very rough and one motor lag behind the other two much to just ignore
    X+ runs smoothly
    X- runs a little rough
    Y- runs a little rough
    Y+ runs smoothly

    Do I need to mess with the dip switches or something
    Dip switch configuration is
    switch 1,2 off
    switch 3 on
    switch 4,5 off
    switch 6,7,8 on

    Thank you.
    Jerry T.
     

    Attached Files:

  15. jltcet

    jltcet Well-Known
    Builder

    Joined:
    Oct 24, 2023
    Messages:
    104
    Likes Received:
    16
    So I've messed around with the different steps on the drivers gotten the the Z, and the X running smoothly but the Y Ive tried every step setting and its the same runs really rough in the Y- position and also one side lags behind to much to ignore. The Y+ runs smoothly no issues Im going to check all the wiring make sure something isnt loose maybe IDK:banghead: Could it be a bad drive?
     
  16. jltcet

    jltcet Well-Known
    Builder

    Joined:
    Oct 24, 2023
    Messages:
    104
    Likes Received:
    16
    So I spend the day trying this and trying that, nothing seems to work on the Y Axis. Until I came across a video where they wired 2 steppers to one drive and BAM!! it works perfectly now every axis works as it should. Thank you everyone who helped me figure this out. Now I just got to figure out why the limit switches don’t respond they seam to be hooked up correctly I can trip them and it show in the open builds software that it’s tripped but it won’t stop the axis's and the alarm won’t reset.
    again thank you everyone
     
  17. Gary Caruso

    Gary Caruso OpenBuilds Volunteer
    Staff Member Moderator Builder

    Joined:
    May 19, 2016
    Messages:
    1,185
    Likes Received:
    531
    Use 1600 microstep, this is most common, or 3200 at the most, they should all be set the same for ease of tuning.
    So now you have both motors hooked up to one driver? and it works?
    Cheers
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice