Welcome to Our Community

Some features disabled for guests. Register Today.

Losing characters between UGS and grbl

Discussion in 'Control Software' started by Phillip Waller, Sep 12, 2018.

  1. Phillip Waller

    Phillip Waller Well-Known
    Builder

    Joined:
    Feb 14, 2017
    Messages:
    2
    Likes Received:
    2
    Just finished a WorkBee1010 with a vPro3 and am using grbl 1.1.

    When I load a file into UGS and send it to grbl I am losing characters. For example;
    g code file line:...................................grbl output panel
    G54....................................................G4
    G1 Z-0.365 F355.6............................G1Z-0.36F3.6
    G17 G2 Y-17.773 J2.935...................G17G2Y-17.773J2.93

    This results in error messages like the following because of characters dropped.

    (error:28) G-code command is missing a required value word.

    (error:2) Missing the expected G-code word value or numeric value format is not valid

    (error:33) Motion command target is invalid.

    I am at a loss for where to start looking for the problem. ANY advice would be most appreciated!!!
    Phil
    43 years a math teacher;
    2 weeks a CNCer.
     
    MaryD likes this.
  2. Gary Caruso

    Gary Caruso OpenBuilds Team
    Staff Member Moderator Builder

    Joined:
    May 19, 2016
    Messages:
    546
    Likes Received:
    206
    Hi Phillip, Check your sender settings.
    There is a truncate setting and a max command length setting.
    You can make the max character setting bigger to 80 for example with no problem, and set your decimal to 3 or 4.
    Not sure why it would lose the 5 on the G54.. Post a file here for us to look at.
    What cam program are you using for making the files?
    Are you using a GRBL post processor?
    Gary

    upload_2018-9-12_17-9-26.png
     
  3. David the swarfer

    David the swarfer OpenBuilds Team
    Staff Member Moderator Builder

    Joined:
    Aug 6, 2013
    Messages:
    984
    Likes Received:
    446
    also, use a quality and short USB cable. and keep it away from power cables.
     
  4. Phillip Waller

    Phillip Waller Well-Known
    Builder

    Joined:
    Feb 14, 2017
    Messages:
    2
    Likes Received:
    2
    I think I have found my difficulty. Even though I set the baud rate in UGS at 115200, Windows 7 insisted on keeping it [at least some of the time] at 9600. Finally got Windows 7 to listen to my demands and the character loss seems to be under control. Thanks for the suggestions!
    Phil
     
    Mark Carew likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice