Welcome to Our Community

Some features disabled for guests. Register Today.

Links in thread that open in new tab - retain login?

Discussion in 'Suggestions' started by Scotty Orr, Oct 12, 2017.

  1. Scotty Orr

    Scotty Orr Veteran
    Builder

    Joined:
    May 21, 2015
    Messages:
    112
    Likes Received:
    31
    Many times I'm reading a thread that has a link to another thread. When clicking that link, a new tab opens in my browser (chrome). I read along in the new tab, and try to click on a resource or photo in the new tab and get the error "You must be logged in to do that". It turns out that I am not logged in on the new tab.

    I haven't discovered a setting in my preferences to take care of this, but it would be nice if when I arrive at a new tab this way, it would recognize that I am logged in. Don't know if this is possible, but thought I'd ask.
    Thanks,
    Scotty
     
  2. MaryD

    MaryD OpenBuilds Team
    Staff Member Moderator Builder

    Joined:
    Apr 13, 2016
    Messages:
    433
    Likes Received:
    445
    We have this same issue occurring on just one of our machines. Our other machines on same version of Chrome are working fine. Bit of a puzzle but we are investigating this issue.
     
  3. Scotty Orr

    Scotty Orr Veteran
    Builder

    Joined:
    May 21, 2015
    Messages:
    112
    Likes Received:
    31
    The machine I've been using is my Mac. I will try with chrome on my Windows laptop and see if it happens there (I'll report back).
     
  4. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    151
    Likes Received:
    116
    If you do find some, post the exact thread (even better the post number (copy the URL to the #<number> in bottom right corner of the reply with the link) - would make it easier troubleshooting from actual examples.
     
  5. Scotty Orr

    Scotty Orr Veteran
    Builder

    Joined:
    May 21, 2015
    Messages:
    112
    Likes Received:
    31
    That will be easy to do. It happens every time that clicking a link to an OpenBuilds page opens a new tab.

    Edit: I take that back - it didn't do it with a "bit.ly/..." link just now. I'll find one and get back to you.
     
  6. Scotty Orr

    Scotty Orr Veteran
    Builder

    Joined:
    May 21, 2015
    Messages:
    112
    Likes Received:
    31
    Here's one: OpenBuilds MiniMill

    There's a link in (post #46) to the C-Beam Build that opens a tab where I am not logged in. (and the link is a full URL, not a bit.ly
     
  7. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    151
    Likes Received:
    116
    Link to C-Beam machine from #46 in that thread does not log me out (in Chrome 61.0.3163.100 Win64) - out of interest, when you use openbuilds, do you come here via openbuilds.com or openbuilds.org. It can happen if you deliberately type openbuilds.org in the browser, then login (onto openbuilds.org) but then click a link like the one mentioned thats openbuilds.com - which would then take you to openbuilds.com for which you do not have a logged in session (.com and .org has seperate cookies) - if thats the case, let me know and i can check if we can force that somehow
     
  8. Scotty Orr

    Scotty Orr Veteran
    Builder

    Joined:
    May 21, 2015
    Messages:
    112
    Likes Received:
    31
    I use Openbuilds.com. I have a tab that remains open on the forum most of the time. (However, I did recently quit all of my sessions in chrome and restarted - still the same.)

    BTW, thanks for looking into it. I'll keep looking to see if something I'm doing is unusual. I'll also check my Chrome settings to see if I've done anything weird there.
     
  9. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    151
    Likes Received:
    116
    Always a pleasure - we are busy revamping the site (switched to new faster server the past weekend, and have a few version upgrades coming up this weekend (which may address this issue by pure luck if we dont find a legit cause otherwise)

    Thanks for your patience - and its really cool knowing that OB tab is open on your browser most of the time! ;)

    PS: also throw a look into the dev-console (ctrl+shift+i -> console tab in chrome) for errors
     
  10. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    151
    Likes Received:
    116
    One more question: How do you login? Using facebook/google login, actual account here on OB?
    Secondly, when you login, do you tick the Keep me signed in box? (If not the forum logs you off after 15 mins of inactivity - i can increase it but the max is 60mins so not much better)
     
  11. Scotty Orr

    Scotty Orr Veteran
    Builder

    Joined:
    May 21, 2015
    Messages:
    112
    Likes Received:
    31
    I login with actual account and yes - keep me signed in. I just noticed one other thing that may be an important clue.

    I was logged in to "openbuilds.com/....(whatever)". I logged out and typed "www.openbuilds.com" and logged in. The behavior was different, but I noticed that in my browser window was "Build List | OpenBuilds....". So I changed the https to "http" without changing anything else and it left me in the thread, but logged me out. So I think it matters how the links I click on are formatted textwise (some are just "www.openbuilds.com" which was most of them when I had just "openbuilds.com". The bit.ly links seem to be OK, but if the formatting of a link otherwise is different than what is in my browser currently, that seems to open the new tab with me logged out (in the new tab).

    However, if no one else can duplicate this, then I've probably got some setting wrong somewhere. I'll keep looking.

    EDIT: That message didn't format correctly - I didn't type "Build List...." I typed "https" then the URL
     
  12. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    151
    Likes Received:
    116
    No no, I'm sure it happens to others too - just probably not reported. It makes sense, and your test reflects my suspicions above as well. I'm onto whats wrong then, but need to sandbox the fix locally (; so will probably roll out a fix in a week or so. Need to rewrite http vs https and www.openbuilds vs http*://openbuilds. and also openbuilds.com vs .org so its all consistent into a single session. Just needs some htaccess tweaking

    Thanks for pointing it out, i'll reply here once i roll out a fix
     
    Scotty Orr likes this.
  13. Scotty Orr

    Scotty Orr Veteran
    Builder

    Joined:
    May 21, 2015
    Messages:
    112
    Likes Received:
    31
    Thanks Peter! :thumbsup:
     
    Peter Van Der Walt likes this.
  14. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    151
    Likes Received:
    116
    We are now rewriting all incoming URLs to "openbuilds.com" - you can give your example link from before a click while already logged in, and see if its resolved. Let me know :)

    Peter
     
  15. Scotty Orr

    Scotty Orr Veteran
    Builder

    Joined:
    May 21, 2015
    Messages:
    112
    Likes Received:
    31
    Actually the behavior of that link in post #46 of the MiniMill thread is even more bizarre: It didn't open a new tab, but it logged me out of the tab I was in!

    (Also, clicking on the link above in this thread - post #6 - had the same behavior as before. Opened a new tab in which I am not logged in.)
     
  16. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    151
    Likes Received:
    116
    Alright i'll revert the change for now and do some more testing
     
    Scotty Orr likes this.
  17. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    151
    Likes Received:
    116
    I did an additional change, and it works when i test it. Could you give it another go :)
     
    Scotty Orr likes this.
  18. Scotty Orr

    Scotty Orr Veteran
    Builder

    Joined:
    May 21, 2015
    Messages:
    112
    Likes Received:
    31
    Yes!! Works great! Even when it opens a new tab, I am now logged in on the new tab!
    Thanks Peter! :thumbsup:
     
    Peter Van Der Walt likes this.
  19. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    151
    Likes Received:
    116
    Awesome man! (; i'll move onto the next cool thing ( ^^^ see icons on the tabs at the top hehe)
     
    Scotty Orr likes this.

Share This Page