Welcome to Our Community

Some features disabled for guests. Register Today.

Issue with CNC (XPro)

Discussion in 'General Electronics' started by TMeh, Nov 11, 2018.

  1. TMeh

    TMeh New
    Builder

    Joined:
    Mar 5, 2017
    Messages:
    1
    Likes Received:
    0
    Hi guys/gals,

    I've got an issue with an OX CNC. Used to work fine, then it didn't!

    Y Axis (Long Axis with Slave Motor) stops working and X axis starts to lose the plot. (Tried 3 times (as seen on the tooling block).
    IMG_2345.JPG

    UGS settings attached. I've got a lot of red lights on the steppers when the machine is turned on. I've put a video clip of when it's operating (before it stopped working).

    I've tweaked the X-Axis so it's on a lead screw. (done ages ago and been working since).

    No obvious error messages in UGS, just stops receiving confirmation of command completed.

    Any tips would be gratefully received. Thanks.

    IMG_0833.JPG

    $0=10 (step pulse, usec)
    $1=255 (step idle delay, msec)
    $2=1 (step port invert mask:00000001)
    $3=6 (dir port invert mask:00000110)
    $4=1 (step enable invert, bool)
    $5=0 (limit pins invert, bool)
    $6=1 (probe pin invert, bool)
    $10=3 (status report mask:00000011)
    $11=0.020 (junction deviation, mm)
    $12=0.002 (arc tolerance, mm)
    $13=0 (report inches, bool)
    $20=0 (soft limits, bool)
    $21=1 (hard limits, bool)
    $22=1 (homing cycle, bool)
    $23=1 (homing dir invert mask:00000001)
    $24=25.000 (homing feed, mm/min)
    $25=500.000 (homing seek, mm/min)
    $26=250 (homing debounce, msec)
    $27=5.000 (homing pull-off, mm)
    $100=200.000 (x, step/mm)
    $101=26.667 (y, step/mm)
    $102=200.000 (z, step/mm)
    $110=5000.000 (x max rate, mm/min)
    $111=5000.000 (y max rate, mm/min)
    $112=5000.000 (z max rate, mm/min)
    $120=50.000 (x accel, mm/sec^2)
    $121=50.000 (y accel, mm/sec^2)
    $122=50.000 (z accel, mm/sec^2)
    $130=550.000 (x max travel, mm)
    $131=1275.000 (y max travel, mm)
    $132=150.000 (z max travel, mm)

    IMG_9844.JPG
     

    Attached Files:

  2. Giarc

    Giarc Master
    Moderator Builder

    Joined:
    Jan 24, 2015
    Messages:
    959
    Likes Received:
    467
    Is there any chance a wire may have come loose, or broke? It seems weird that it worked but now doesn't, unless another setting got changed. I thought someone recently had a similar problem then found they had a loose wire. Also, if the wheels somehow tightened up that can cause step loss.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice