Welcome to Our Community

Some features disabled for guests. Register Today.

I'm at a loss now. No clue what to do. GRBL Settings wrong?

Discussion in 'CNC Mills/Routers' started by iH8vols, Oct 7, 2017.

  1. iH8vols

    iH8vols Well-Known
    Builder

    Joined:
    Dec 4, 2016
    Messages:
    19
    Likes Received:
    1
    I had my machine setup and was close to beginning to smooth my spoiler board. i did one last check and wrote my name on a piece of scrap wood. It was then I realized my axis were set up backwards because it wrote my name like you would see the word "Ambulance" on the front a unit so it's visible in the rear view mirror.

    I read up on the GRBL settings and saw that I needed to change $3 to 2. I made that change and then started with a home command and it changed my home position. Prior to the $3 change I had home in corner #2, my preferred spot if possible (see label on attached photo).

    I then read where I could change setting $23 to fix this, so i changed it to 2.

    At this point I felt pretty confident with everything. I homed the machine and then jogged it to the max distances so I could enter the soft limits.

    Next, I put my name file back into Universal GCode Sender to see if it wrote my name correctly. I moved the router bit to almost touching the wood and reset it. I held "send" and the router moved UP (instead of down) about a qtr inch which is what I had it set to on cutting depth. The machine then stopped and gave me a soft limits warning. I'm nowhere near the max positions. I've tried reloading the gcode file and still nothing.

    Any suggestions on what i've done to screw this up? I feel like I went from almost ready to cut a test to a completely unusable machine in about 10 minutes. I'll post my GRBL code below in case that helps.

    Now, i've tried just cutting something small, and I get constant soft limit errors. doesn't matter how small i make the cutout or where i position the router on the table, it stops the code immediately after me hitting "Send" and gives me the SL error. I set $132 to 905 in to eliminate any possibility of the Z axis causing the SL errors. Normally, I don't keep it anywhere close to that.

    Is there a video or a step by step walk thru on how to setup everything within UGS? At this point, I have no problem starting over and getting my settings back in order. I just don't know where to start on troubleshooting or even starting over. I've looked at youtube, but I've not found anything that will help.

    I appreciate your help.



    $0=10 (step pulse, usec)
    $1=255 (step idle delay, msec)
    $2=3 (step port invert mask:00000011)
    $3=2 (dir port invert mask:00000010)
    $4=1 (step enable invert, bool)
    $5=0 (limit pins invert, bool)
    $6=0 (probe pin invert, bool)
    $10=3 (status report mask:00000011)
    $11=0.020 (junction deviation, mm)
    $12=0.002 (arc tolerance, mm)
    $13=0 (report inches, bool)
    $20=1 (soft limits, bool)
    $21=0 (hard limits, bool)
    $22=1 (homing cycle, bool)
    $23=2 (homing dir invert mask:00000010)
    $24=2500.000 (homing feed, mm/min)
    $25=2500.000 (homing seek, mm/min)
    $26=250 (homing debounce, msec)
    $27=5.000 (homing pull-off, mm)
    $100=26.667 (x, step/mm)
    $101=26.667 (y, step/mm)
    $102=100.000 (z, step/mm)
    $110=3000.000 (x max rate, mm/min)
    $111=3000.000 (y max rate, mm/min)
    $112=1000.000 (z max rate, mm/min)
    $120=2000.000 (x accel, mm/sec2)
    $121=2000.000 (y accel, mm/sec2)
    $122=1000.000 (z accel, mm/sec2)
    $130=1259.000 (x max travel, mm)
    $131=565.500 (y max travel, mm)
    $132=905.000 (z max travel, mm)
     

    Attached Files:

  2. Kevon Ritter

    Kevon Ritter Veteran
    Builder

    Joined:
    Apr 30, 2015
    Messages:
    216
    Likes Received:
    63
    ENTIRE POST EDITED:

    According to your picture, your axis are labeled wrong. Your x should be side to side, not fore and aft. You're going against standard convention and using opposing coordinate systems all at the same time. The machine is essentially going to be fighting both you and itself.

    + is the far right corner
    - is the close left corner
    x goes from left to right (- to +)
    y goes from close to far(- to +)
    z is the only correct axis

    Just to clarify...
    1 = -x,-y
    2 = -x,+y
    3 = +x,+y
    4 = +x,-y
    You fix this by rewiring your steppers. Every single stepper should be wired exactly the same as the other, just to a different driver.

    Make sure you get all of then moving the correct direction without any inverting functions active. So reset the following to 0.
    $2=0
    $3=0
    $23=0

    Also disable soft limits for now.
    $20=0

    Reset your max travels accordingly. You'll need this later. You can always go under for testing. I would also start away from the edges during testing.
    Example:
    $130=200
    $131=300
    $132=60

    Check to see what the values are for your G28 and G30 commands. They should be 0 on all axis for now.
     
    #2 Kevon Ritter, Oct 8, 2017
    Last edited: Oct 8, 2017
    iH8vols likes this.
  3. iH8vols

    iH8vols Well-Known
    Builder

    Joined:
    Dec 4, 2016
    Messages:
    19
    Likes Received:
    1
    I got it!! Thank you for the explanation. Made perfect sense after reading your post. Really appreciate it!!!
     
  4. Kevon Ritter

    Kevon Ritter Veteran
    Builder

    Joined:
    Apr 30, 2015
    Messages:
    216
    Likes Received:
    63
    No problem, just let us know how it goes.
     

Share This Page