Welcome to Our Community

Some features disabled for guests. Register Today.

Hit a stumbling block that i cant figure out,in need of help..

Discussion in 'Laser Cutters' started by Benny the builder, Sep 7, 2018.

  1. Benny the builder

    Benny the builder Well-Known
    Builder

    Joined:
    Sep 1, 2018
    Messages:
    2
    Likes Received:
    1
    First post but ive been reading and trying to learn few a few months, I've tried to expand my k40 laser using v-slot and its not gone to bad considering im a complete novice. My stumbling block is my endstops and i dont know were to go in determining how to fix it. I started this project to learn more about electric and laser/cnc machines but now im stuck, so im hoping you knowledgeable lot can help out?

    K40's meant to home in the top left but the X axis is trying to go the right obviously not finding a endstop so crashing if i let it be, ive jumped the X axis and its still doing the same thing, but i will triple check that again when i get in later. ive also connected the cohesion mini board and that doing the same so am i correct in saying its not the board? I've also wire completely new endstops and their doing the same also?

    And this is were my knowledge stops and i am stumped, i had problems with the originals ones (jumped them and then they worked as should, so knew it was the optical switches) so i changed them to mechanical stop from optical and that fixed it but now its playing up again and i don't know were to start?

    At the moment ive put a end stop on the X axis up in the right hand corner and i can now use my laser but its back to front from whats on my screen, to what its burning on my material ! I even fitted mini 3d board with the end stop X axis on the the top right changed the origin point to top in the setting and its works but not quite correctly. If i left it top left in setting on cohesion board the jog option does not work correctly at all.

    Thanks in advance guys, any more information needed please ask away, i can do videos and pictures if that helps.
     
  2. Gary Caruso

    Gary Caruso OpenBuilds Team
    Staff Member Moderator Builder

    Joined:
    May 19, 2016
    Messages:
    525
    Likes Received:
    198
    Hi Benny,
    If a motor is going the wrong way just swap one of the two motors coils wires around. it's not the limit switches, your machine doesn't know where they are. ;)
    Or you have to program your board to set the home direction. But not enough info to know if this is the issue. :)
    Not sure what "Jumped them all" means? Pics and details would help.
    Are you using the Cohesion board normally? i'm sure in smoothieware you can set the home seek direction.
    just looked.. never used smoothie but found it quick enough..
    upload_2018-9-7_21-7-18.png
    Cheers
    Gary
     
    #2 Gary Caruso, Sep 7, 2018
    Last edited: Sep 7, 2018
    Mark Carew likes this.
  3. Benny the builder

    Benny the builder Well-Known
    Builder

    Joined:
    Sep 1, 2018
    Messages:
    2
    Likes Received:
    1
    • Cheers Chris, i fixed that and its engraving/homing in the the right place now..
    thanks for your help, ive got more issues with it but are start new threads that are appropriate for the issue..
     
    GrayUK likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice