Welcome to Our Community

Some features disabled for guests. Register Today.

GRBL Z axis runs + during probe/autolevel only

Discussion in 'CNC Mills/Routers' started by DynamicDesignsEngineering, May 17, 2018.

  1. DynamicDesignsEngineering

    Builder

    Joined:
    May 17, 2018
    Messages:
    4
    Likes Received:
    0
    Ok, I am going out of my mind here! I have a small desktop CNC mill for trace isolation on PCB's. It runs GRBL 1.1f on an arduino Nano. I have tried using both GRBL Controller/Candle as well as UGS Platform, and both have the same result. All works well, all axis rn the correct direction when jogging and homing, but when I prob/autolevel/surface map, the Z runs positive until it hits the limit switch (Hard Limit) and goes into gcode lock. I have got the Alarm 4 and then of course the corresponding error 9.
    Considering that I have the same issue with both programs, it leads me to believe it's a setting on the controller. Below is a list of my controller settings. I have searched, and searched, and searched online to no avail as nobody has had this EXACT issue. If anyone has any insight, it would be greatly appreciated.
    I have reported values set to mm for now($13), Hard Limits enabled($21 - with limit switches on +X,+Y,+Z ,and -Z on the PCB and V-Bit and all working fine per verbose output), Homing enabled($22), Homing direction set accordingly - all axis move correctly in homing sequence, and sequence completes), Homing pull off at 5 mm($27), and steps per mm are calculated and set - verified by measuring the distance moved with calipers).

    thanks in advance!
    Nate

    $0=10
    $1=25
    $2=0
    $3=0
    $4=0
    $5=0
    $6=0
    $10=1
    $11=.010
    $12=.002
    $13=0
    $20=0
    $21=1
    $22=1
    $23=0
    $24=25
    $25=25
    $26=250
    $27=5
    $30=3000
    $31=0
    $32=0
    $100=800
    $101=800
    $102=800
    $110=500
    $111=500
    $112=500
    $120=10
    $121=10
    $122=10
    $130=100
    $131=100
    $132=100
     
  2. Mark Carew

    Mark Carew OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Builder

    Joined:
    Jun 28, 2013
    Messages:
    2,036
    Likes Received:
    1,289
    Hi Nate, I do not have a probe set up, but I did a little research and saw that it could be a work offset issue causing this behavior.
    Take a look here and see if there is not some information that may help you out.
    Please be sure to let us know here how you make out and maybe some of the guys that are probe savvy will chime in here with some ideas as well.
     
  3. DynamicDesignsEngineering

    Builder

    Joined:
    May 17, 2018
    Messages:
    4
    Likes Received:
    0
    Not much in there, but I can check the Work Offsets. I still am not seeing how that will reverse the Z-axis direction when probing. Hopefully someone else will have some insight.
     
  4. DynamicDesignsEngineering

    Builder

    Joined:
    May 17, 2018
    Messages:
    4
    Likes Received:
    0
    Can anyone tell me exactly what could cause this error?
    "(ALARM:4) Probe fail. Probe is not in the expected initial state before starting probe cycle when G38.2 and G38.3 is not triggered and G38.4 and G38.5 is triggered."
    When I execute the command, it will jog X,Y, and then stop with this alarm. Not sure what exactly it is telling me.

    Thanks.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice