Welcome to Our Community

Some features disabled for guests. Register Today.

GRBL doesn't save home position

Discussion in 'Control Software' started by harlandraka, Oct 24, 2017.

Tags:
  1. harlandraka

    Builder

    Joined:
    Sep 22, 2017
    Messages:
    4
    Likes Received:
    0
    Hi everyone, I'm trying to set GRBL up for my new DLP printer.

    I disabled homing for X and Y axes in the config.h file as I just have the Z axis by commenting this line:

    Code:
    #define HOMING_CYCLE_1 ((1<<X_AXIS)|(1<<Y_AXIS))

    This is the output of $$:
    Code:
    $0=10
    $1=25
    $2=0
    $3=0
    $4=0
    $5=0
    $6=0
    $10=1
    $11=0.010
    $12=0.002
    $13=0
    $20=0
    $21=0
    $22=1
    $23=4
    $24=25.000
    $25=200.000
    $26=250
    $27=1.000
    $30=1000
    $31=0
    $32=0
    $100=250.000
    $101=250.000
    $102=1600.000
    $110=500.000
    $111=500.000
    $112=500.000
    $120=10.000
    $121=10.000
    $122=10.000
    $130=200.000
    $131=200.000
    $132=200.000
    I connected my endstop and tried to home with $H. It works, the Z axis goes down until it reaches the endstop, then goes a bit up and goes down again slowly until it hits the endstop again, then it goes a bit up again.

    The issue is that the home position isn't saved.

    After this, I tried running:

    Code:
    G1 Z0 F100
    After running this line, the Z axis moved exacly to the point where it was when I powered on the Arduino. It seems that the first Z position was saved and that $H did not overwrite it.

    How do I make GRBL remember the last home position reached with $H?

    Thank you
     
  2. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Contest Winner! Builder

    Joined:
    Mar 1, 2017
    Messages:
    142
    Likes Received:
    111
    Have a read through Set up the Homing Cycle · gnea/grbl Wiki · GitHub to ensure your settings are correct

    You may also wanted look into Grbl WCS (Work Coordinate Systems) - mPos is set via Homing, but your work coordinate system (wPos) may not be. In which case the G10 command is your friend
     

Share This Page

  • About Us

    The OpenBuilds Team is dedicated helping you to Dream it - Build it - Share it! Collaborate on our forums and be sure to visit the Part Store for all your Maker needs.


    [email protected]

  • Like us on Facebook

  • Support Open Source FairShare Program!

    OpenBuilds FairShare Give Back Program provides resources to Open Source projects, developers and schools around the world. Invest in your future by helping others develop their future.

    Donate to Open Source