Welcome to Our Community

Some features disabled for guests. Register Today.

GBRL - CNC Shield - A4988

Discussion in 'CNC Mills/Routers' started by WayneKellen, Sep 24, 2017.

  1. WayneKellen

    Builder

    Joined:
    Sep 23, 2017
    Messages:
    2
    Likes Received:
    0
    I have an old MiniTech Minimill-2. It had its own control with a parallel port interface. I tried communicating with it with an Arduino and GBRL v.9. I could power it up, but could not get any movement out of it. I removed the cover of the control and found someone had been in there working on it before.

    I decided to scrap the control for the arduino, cnc shield, and A4988 drivers. While assembling everything, I found the existing steppers were 5 wire unipolar 35 oz-in. I messed one up cutting the trace to convert it to 4 wire bipolar. I also found one was shot, so I bought 3 new 4 wire bipolar stepper motors.

    Since I was tearing it apart this far, I cleaned the whole thing up. I got all guides clean and sliding very good and all acme screws clean and lubed. Surprisingly everything is in really good shape.

    I assembled everything except for putting the table and the spindle on it. I wanted to make sure there were no issues while I could still see and get to everything. I am supplying 12v via a trolling motor battery to the cnc shield. I plan to use a computer power supply. While wiring the motors, I noticed 2 different layouts. One was a picture of the CNC shield with labels beside the pins. Top to bottom it shows B2, B1, A1, A2. On a schematic for the A4988, it showed top to bottom 2B, 2A, 1A, 1B. Looking at it I thought these were the same where B1 and B2 are the same as 2A and 2B (Top to bottom would be negative and positive of the 1st coil then positive and negative of the 2nd coil).

    Wiring the motors this way, I got smooth movement out of the Y axis. No movement out of the X axis, but a lot of noise. No movement out of the Z axis and a very faint hum.

    This is where I thought maybe the 2 different layouts are not the same. Maybe the A4988 requires the 1A, 2A together and 1B, 2B together. This would put the middle 2 pins to the 1st coil and the outside 2 pins to the 2nd coil. I swapped some wires and give it a go. This time I got smooth movement out of the X axis. No movement and a lot of noise out of the Y axis. No movement out of the Z axis and a faint hum. I did find out I could spin the Z by hand and then the motor would spin it. Now I am totally confused.

    I wired the Y axis back the way it was. Now I got smooth movement out of the X and Y axis. The Z moved, but if you jog in the + direction, it will move up and then the second time you hit the + it will move down. I tried running a program. The X and Y moved good. The Z never moved at all.

    What is the correct wiring and why are all the motors behaving differently?

    Thanks in advance.
     
  2. Gary Caruso

    Gary Caruso Veteran
    Builder

    Joined:
    May 19, 2016
    Messages:
    242
    Likes Received:
    88
    Edit; i re-read what you wrote and yes this is confusing !!

    weather it's A - B or B- A makes no difference, as long as A's are together in some order and B's are together it will turn but might be in wrong direction polarity determines direction but you can change that later or in software.
    the ones not turning you must not have the coils paired up, or you are not driving the stepper hard enough to overcome friction (Current too low).. best to test with the motors disconnected from the screws.
    what is weird to me...
    Looks like the pinouts are 1A -1B 2A-2B.. So ignore what i said, they have the 1's together (A and B) and the 2s together (A and B) at least according to this drawing!

    upload_2017-9-27_16-15-11.png
     
    #2 Gary Caruso, Sep 27, 2017
    Last edited: Sep 27, 2017
  3. WayneKellen

    Builder

    Joined:
    Sep 23, 2017
    Messages:
    2
    Likes Received:
    0
    Thanks for the reply. I somewhat figured it out. It basically works as + - + -. I had 1 wired messed up and coils were not together as you said. My z port on the cnc shield seems to be bad. I fixed the wiring on the one. X and Y moved correctly. Some skipping in a return to home command. Rapid feed must be set too high. I metered the drivers and set them for 1.25A output. Again X and Y were good, but no Z movement. I powered everything off and moved my Z motor to my X port. Tried again and the Z moved perfectly. I thought maybe I messed up a driver. The kit had 3 extras in it, so I swapped the Z driver out. Still nothing. I cloned the Z axis to the A port and everything moves. Now I just need to nail down the top rapid speed and then calibrate the machine. I have no idea what the pitch is on the acme screws, so I will have to trial and error it with a 1" travel indicator.
     

Share This Page