Welcome to Our Community

Some features disabled for guests. Register Today.

CNC XPro v3 malfunction

Discussion in 'Controller Boards' started by TechMav, Jan 16, 2017.

  1. TechMav

    TechMav New

    Apr 1, 2016
    Likes Received:
    Having a bit of a problem with my v3. It had been working fine, then suddenly 'locked up' X and Z axis will not move. Motors are holding, and resist being turned by hand. Any attempt to jog the position shows no movement of the motor, and no increase/decrease in position in the software. BUT, if I try to move the Y axis, it will unlock all the motors, show a position change in the software, then relock all the motors when the move finishes, but the Y-axis motor doesn't actually move.

    I've tried two different computers, two different USB cables, and two different GRBL senders, to eliminate the possibility of a failure there. I've allowed it to cool overnight in case it was a thermal issue. I've also reloaded the GRBL firmware in case it got corrupted. I've changed motors.

    Running a 24V switchmode power supply, tried bCNC and UGS, and a Raspberry Pi and a laptop, both of which previously worked. The power supply is putting out 24V, and is also running the Pi, so it's not dropping out.

    At this point, the only thing I can come up with is the XPro board itself has failed.

    Any suggestions??

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice