Welcome to Our Community

Some features disabled for guests. Register Today.

cnc skipping steps (cw5045 driver + Nema23 4Nm motor)

Discussion in 'CNC Mills/Routers' started by jacek.a, Feb 8, 2015.

  1. jacek.a

    jacek.a New
    Builder

    Joined:
    Nov 27, 2014
    Messages:
    1
    Likes Received:
    0
    Hi all!

    I have a problem with a CNC I've recently built. I use UCCNC software, the drivers are CW5045, and some breakout board from cnc4you (5-axis). The motors are Nema23 4Nm, the system frame is about 2m by 1.2m.

    There is a problem with proper calibration of the CNC. Sometimes the system does not return to the starting position along the axes (even in calibration mode). From what I understand it is related to motors missing steps (for reasong unknown to me). Also, when cutting in the wood the dimensions are always smaller than what they should be. I have already tried different speeds (I have slowed down the linear speed to 2m/min. it barely helped). The most annoying thing is that sometimes the CNC works fine, making few perfect moves and then it loses 1mm along 5cm line.

    I would greately appreciate any help.
     
  2. David the swarfer

    David the swarfer OpenBuilds Team
    Staff Member Moderator Builder

    Joined:
    Aug 6, 2013
    Messages:
    985
    Likes Received:
    448

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice