Welcome to Our Community

Some features disabled for guests. Register Today.

bCNC Axes in View window on Raspbery Pi

Discussion in 'Control Software' started by Shawn Brown, Mar 10, 2018.

  1. Shawn Brown

    Builder

    Joined:
    Nov 8, 2016
    Messages:
    4
    Likes Received:
    0
    This past winter I finally got around to assembling my C-Beam XL. Everything is built, wired and moving. I have the steppers moving in the correct direction and am homing with Z up, X left and Y at the front corner, as you look at the machine.

    I've been struggling with the setup of bCNC and the Axes layout window. (Is that what it is called?) In the image below, you can see that the coordinate axes are way off the front left corner of the layout rectangle. When I home the machine, it aligns the bit correctly with the Axes as shown by the red triangle. Any ides of where I put something in wrong?

    I'm using bCNC version 0.9.14 running on a Raspberry Pi. I added by GRBL settings and my bCNC config settings.

    bCNC-Layout.PNG

    GRBL Config:

    $$
    $0=10
    $1=25
    $2=0
    $3=6
    $4=0
    $5=1
    $6=0
    $10=1
    $11=0.010
    $12=0.002
    $13=0
    $20=1
    $21=1
    $22=1
    $23=3
    $24=25.000
    $25=500.000
    $26=250
    $27=1.000
    $30=1000
    $31=0
    $32=0
    $100=250.000
    $101=250.000
    $102=250.000
    $110=2750.000
    $111=2000.000
    $112=1000.000
    $120=40.000
    $121=40.000
    $122=20.000
    $130=730.000
    $131=320.000
    $132=40.000
    ok

    bCNC-Config.PNG
     
  2. Kyo

    Kyo Master
    Staff Member Resident Builder Builder

    Joined:
    Feb 27, 2014
    Messages:
    647
    Likes Received:
    610
    This can be corrected by uploading grbl from source using the Arduino IDE. You will need to uncomment line 129 of config.h ( #define HOMING_FORCE_SET_ORIGIN ) by default grbl will place the machine in negative space, so what bCNC is showing is correct. To have grbl zero at the home position just uncomment the above line and this is what you will get after homing. Hopes this helps :thumbsup:

    Bcnc_Screenshot.jpg

    Edit: If you are still running one of my older boards you will also need to uncomment.
    Line 360: #define USE_SPINDLE_DIR_AS_ENABLE_PIN

    And possibly, depending on board rev.
    Line 169: #define ENABLE_M7
     
    #2 Kyo, Mar 10, 2018
    Last edited: Mar 10, 2018
  3. Shawn Brown

    Builder

    Joined:
    Nov 8, 2016
    Messages:
    4
    Likes Received:
    0
    Thanks for that info! I was running the most recent GRBL 1.1 pre-built image. I never even considered looking through those files to compile something different than the pre-built image. Or at least until I started playing with spindle controls. Once that time came, I figured I may need to play around with config.h to get the spindle settings working. So thanks for the heads up on those settings as well. The config.h has some really good documentation in it. Wish I would have looked at that earlier.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice