Welcome to Our Community

Some features disabled for guests. Register Today.

workbee can't return to exact g54 position

Discussion in 'CNC Mills/Routers' started by andreashalim, Mar 6, 2019.

  1. andreashalim

    Builder

    Joined:
    Sep 28, 2017
    Messages:
    5
    Likes Received:
    0
    hi there,
    workbee user here. i ran a few test on my workbee, apparently it couldn't return to exact g54 position.
    after did some operation.
    im using arduino uno as my controller, TB6600 stepper driver and Universal Gcode Sender as my gcode interpreter

    so here's the picture:

    i mark my endmill with black marker. plunged it down to the spoilboard to mark it and zero the position

    WhatsApp Image 2019-03-06 at 11.44.58 AM.jpeg

    i ran a 2D pocketing operation, after it finish, i return it to work zero position (G54), and this is what its look like
    WhatsApp Image 2019-03-06 at 11.44.58 AM.jpeg WhatsApp Image 2019-03-06 at 11.44.58 AM(1).jpeg

    i did the same operation again, return it to work zero position.
    WhatsApp Image 2019-03-06 at 11.44.58 AM(2).jpeg

    i draw a conclusion that somehow my g54 position has been moved.
    The problem could be mechanical or hardware issue, or maybe a combination of both.

    i checked the belt tension, checked all the screws and wheels.
    i didnt hear the clicking sound from stepper as if it was skip some steps
    im using 1/8 microstepping.

    what probably cause the issue?
     
  2. sharmstr

    sharmstr Master
    Moderator Builder

    Joined:
    Mar 23, 2018
    Messages:
    357
    Likes Received:
    211
    Did you check your pulley? It might be loose.
    Did you calibrate your steps/mm?

     
  3. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Builder

    Joined:
    Mar 1, 2017
    Messages:
    866
    Likes Received:
    527
    Might want to replace the cheapies with decent drivers (; DQ542MA Stepper Motor Driver
    The TB6600s sometimes need a longer step pulse (Grbl settings -> Increase pulse time)
     
    sharmstr likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice