Welcome to Our Community

Some features disabled for guests. Register Today.

When I start a job, the machine just moves to the opposite corner and crashes

Discussion in 'Control Software' started by McFuddlebutt, Nov 8, 2019 at 12:24 AM.

  1. McFuddlebutt

    Builder

    Joined:
    Oct 9, 2017
    Messages:
    18
    Likes Received:
    1
    Howdy guys!

    I'm having a little bit of trouble with a machine I just (finally) finished. Using Openbuilds CAM for the G-Code and Openbuilds Controller for the.....controlling.

    It's a Large Sphinx build that is 1000mm long on the Y Axis, and 600 (ish) wide on the X axis. It's connected using a Black Box I bought last week.

    If you're standing in front and facing the machine, the origin point is the left corner closest to you. When I select Home All, it works without issue. When I select "Size Check" or start the job (hello world) however, the machine will jog the X axis to the far end of the machine until it crashes (I guess I should install limit switches on the other side as well?) and the Y axis travels to the far right corner of the machine. I haven't given it a chance to move all the way down because the X crashes first and I hard stop the machine.

    I'm pretty sure this is a GRBL setting I've goofed up but I thought I'd ask you guys for assistance.
     
    #1 McFuddlebutt, Nov 8, 2019 at 12:24 AM
    Last edited: Nov 8, 2019 at 1:02 AM
  2. David the swarfer

    David the swarfer OpenBuilds Team
    Staff Member Moderator Builder

    Joined:
    Aug 6, 2013
    Messages:
    1,327
    Likes Received:
    675
    Did you load the default settings from OpenBuildsCONTROL?
    select 'GRBL settings'
    select your machine from the list next to the [1]
    select 'save to firmware'
    select 'restart'

    That should inform the conitroller of the size of the machine.

    now, if that is all correct.... you did not mention setting the work offsets.
    I wrote about this just the other day .
     
  3. McFuddlebutt

    Builder

    Joined:
    Oct 9, 2017
    Messages:
    18
    Likes Received:
    1
    Thank you for the reply, David! I'm sitting at the machine as we speak. I'll give that a look.
     
  4. McFuddlebutt

    Builder

    Joined:
    Oct 9, 2017
    Messages:
    18
    Likes Received:
    1

    So I selected Sphinx and it appeared to try and perform the size test in the correct corner, however it flipped the Y axis so it's trying to travel to the other side of the machine looking for a limit switch. When I disable reverse Y axis, it goes back to the old problem. Is there a way to tell the software, this is the home point no matter what direction the motors are moving in?
     
  5. Alex Chambers

    Alex Chambers Master
    Moderator Builder

    Joined:
    Nov 1, 2018
    Messages:
    1,027
    Likes Received:
    508
    Hi @McFuddlebutt, @David the swarfer is far more knowledgable on this than I am, so you may have to wait for someone like him to reply, but just to confirm;

    are you setting machine co-ordinates (home) front/left/down (Y/X/Z)?

    if you could post your grbl settings here it would make it clearer what you have told the machine to do.

    In the meantime it would be worth reading gnea/grbl

    Alex.
     
  6. McFuddlebutt

    Builder

    Joined:
    Oct 9, 2017
    Messages:
    18
    Likes Received:
    1

    Thank you for the reply, Alex!

    I will get right on reading through the git documentation. How do I go about exporting my grbl settings? Or do I manually type them out?

    Thank you again!
     
  7. SugarJ

    SugarJ Well-Known
    Builder

    Joined:
    Nov 16, 2015
    Messages:
    120
    Likes Received:
    47
    There is a setting to reverse the homing directions. GRBL default is Z up, X Right, Y back (or Z max, X max, Y max) . This is different than reversing your X, Y, Z travel direction. If your homing limit switches are at the front left position, you need to reverse the homing direction on X and Y.

    Don't do this until you have your jogging working in the right direction, that's your first task. i.e. it goes right when you jog X+, away when you jog Y+. Then set your homing directions as needed.
     
  8. McFuddlebutt

    Builder

    Joined:
    Oct 9, 2017
    Messages:
    18
    Likes Received:
    1
    Ok guys, I think I got it. I needed to first invert the X direction, then make sure both the X and Y axis homing directions were inverted. I guess it thought the machine was essentially flipped. Thank you all for your help!
     
    Alex Chambers likes this.
  9. David the swarfer

    David the swarfer OpenBuilds Team
    Staff Member Moderator Builder

    Joined:
    Aug 6, 2013
    Messages:
    1,327
    Likes Received:
    675
    ok, what we first need to do is make sure the machine goes in the correct directions
    after that we can make homing work in the correct directions.
    I described this process earlier this week...... At wit's end
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice