Welcome to Our Community

Some features disabled for guests. Register Today.

Unable to check Firmware and GRBL not connecting

Discussion in 'Interfaces' started by Federico77, May 21, 2021.

  1. Federico77

    Builder

    Joined:
    Nov 19, 2018
    Messages:
    16
    Likes Received:
    4
    Hello,

    a few weeks ago I received Interface to add my Workbee 1510. I was already happily using Blackbox since a year and it was about time to add something more to my setup.

    Unfortunately it looks like Interface is not connecting to the Blackbox despite following the online guides and faq. During boot it fails the firmware and Grbl checks and requests to check AUX Serial connector before trying again.

    I obviously did it and started the troubleshooting by verifying both that pins were not broken (on both devices) and that cable signals were fine to both side on all the 4 pins. Of course I also made sure that if AUX is connected USB is not.

    Once I did this the next logical step was to upgrade both firmwares, one at a time and checking after each upgrade. I started with Blackbox that went from VER:1.1f.20170801:WORKBEE1510 to VER:1.1g.20181112:WORKBEE1510 through latest Control version wizard (1.0.301 at the time of writing).
    Nothing changed so I also upgraded Interface firmware to v.1.47 (sadly I cannot confirm the previous version).
    Still no improvements except from my skills at the included jump game...

    I don't know what else to do. Can anyone offer some help please?

    Thanks,
    Federico
     
  2. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Project Maker Builder Resident Builder

    Joined:
    Mar 1, 2017
    Messages:
    7,833
    Likes Received:
    2,606
    If BlackBox is up and running, and the USB cable disconnected (Check?), and you did perform all the Preparation steps (See docs:interface:prepare-blackbox [OpenBuilds Documentation] (Check?)
    Then the only thing in play is the cable itself.


    Requires an active Wifi connection, which you can only setup later once you have succesfully booted up, so totally normal at this time


    Remember to beat the record Interface Game (High Scores)
     
  3. Federico77

    Builder

    Joined:
    Nov 19, 2018
    Messages:
    16
    Likes Received:
    4
    Dude, this answer was fast! I may have spotted were the problem is... as silly as I am I forgot to actually RTFM twice. What a noob!
    I mean: I did it as soon as I received Interface and assembled it but I now remember I said: "as soon as I get to the Blackbox I'll see which board version it is". I obviously forgot to do that step when a few weeks later I finally brought the new device to my garage.

    Sooooo, now I know I have a board rev. 2.3 and I just ditched the transistor and plugged in the ICSP module as requested... in a few hours I will be able to check if this solved my problem but I believe it does.

    I'd keep this thread open just to confirm/deny that it's solved but I am super grateful for the help.

    I'll check the highscores soon too! :)
     
    Peter Van Der Walt likes this.
  4. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Project Maker Builder Resident Builder

    Joined:
    Mar 1, 2017
    Messages:
    7,833
    Likes Received:
    2,606
    Very very likely that would've been it :)

    Keep us posted
     
  5. Federico77

    Builder

    Joined:
    Nov 19, 2018
    Messages:
    16
    Likes Received:
    4
    That indeed was it. Works like a charm!
    Thanks a lot for the help!
     
    Peter Van Der Walt likes this.
  6. Jeremy2020

    Builder

    Joined:
    Jul 21, 2021
    Messages:
    10
    Likes Received:
    2
    Hello! It looks like the cable for my interface isn't working and the interface won't stay lit up / powered. It will only power when connected to laptop with USB C. How do I order a replacement cable for interface?
     
  7. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Project Maker Builder Resident Builder

    Joined:
    Mar 1, 2017
    Messages:
    7,833
    Likes Received:
    2,606
    Contact the Store via the Contact us page on Openbuildspartstore.com :)
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice