Welcome to Our Community

Some features disabled for guests. Register Today.

SuperPID and Grbl Config help

Discussion in 'Controller Boards' started by Rendermandan, Oct 19, 2018.

  1. Rendermandan

    Rendermandan Veteran
    Builder

    Joined:
    Dec 4, 2015
    Messages:
    65
    Likes Received:
    46
    I am trying to hook up my SuperPID to an Arduino Uno running GRBL V1.1.
    The problem I'm having is how to hook up the "Run" connection on the SuperPID. It is supposed triggered by the Spindle Enable pin on the Arduino pin 13. However even after uploading GRBL to the Arduino, the pin 13 led light flashes on the board which in turn causes the SuperPID to constantly turn the "Run" on and off.

    I have looked into the GRBL config.h files and already enabled VARIABLE_SPINDLE for the PWM signal.
    I also enabled USE_SPINDLE_DIR_ENABLE_PIN.

    I am still having trouble getting this to work. Has anyone else had any luck?

    Thanks.
     
    #1 Rendermandan, Oct 19, 2018
    Last edited: Oct 20, 2018
  2. Rendermandan

    Rendermandan Veteran
    Builder

    Joined:
    Dec 4, 2015
    Messages:
    65
    Likes Received:
    46
    So I was able to finally figure it out. I needed to enable the invert pin.
    INVERT_SPINDLE_ENABLE_PIN

    Now it works!
     
    sharmstr and Rick 2.0 like this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice