Welcome to Our Community

Some features disabled for guests. Register Today.

Spindle Control Help Please

Discussion in 'Motors' started by Atterius, Jul 10, 2019.

  1. Atterius

    Atterius New
    Builder

    Joined:
    Jul 10, 2019
    Messages:
    1
    Likes Received:
    0
    Hi everyone, I have recently set up GRBL on an Uno with the CNC shield, everything seems to work except the spindle on and off, If i am understanding it correctly the spindle enable pins on the board send a 5v to a solid state relay i have set up for my spindle, the problem i am having is as soon as i power up my Uno its sending that 5V, I have tried M3 and M5 nothing changes, I send M03 and M05 nothing changes,, still getting the same 5V to the spindle enable pins..

    Am i not understanding how or what the spindle enable pins work,, The text i have seen all say that M3 turns the spindle on and M5 Off
    so I figured M3 would enable the spindle enable pins with 5v and M5 would disable the 5v to the pins...

    Any help would be welcome,, thank you
     
  2. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Builder

    Joined:
    Mar 1, 2017
    Messages:
    1,392
    Likes Received:
    737
    M3S1000

    S-word sets the PWM value. For SSR you cannot actually PWM so never set it to anything but S1000 (and assumed Grbls settings for Max Spindle RPM is set to 1000 too)
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice