Welcome to Our Community

Some features disabled for guests. Register Today.

sketchucam problem

Discussion in 'CAM' started by leroy spronk, Jul 4, 2019.

  1. leroy spronk

    Builder

    Joined:
    Jun 29, 2019
    Messages:
    2
    Likes Received:
    1
    Hi there i installed sketchucam and every time i try to plot the gcode i created i geth a warning the safty height on my z axcis is not a valid floating point value. Can someone tell me whats wrong

    greatings leroy
     
    #1 leroy spronk, Jul 4, 2019
    Last edited: Jul 4, 2019
  2. David the swarfer

    David the swarfer OpenBuilds Team
    Staff Member Moderator Builder

    Joined:
    Aug 6, 2013
    Messages:
    1,305
    Likes Received:
    655
    Are you seeing this warning when Sketchup starts?
    upload_2019-7-5_9-26-5.png

    Gcode does not follow regional settings for decimal separators, it ALWAYS uses the . (dot) for floating point values.
    BUT Sketchup is aware and formats numbers using the Windows regional settings (and there is no way in the code to prevent this), so you need to make sure that your decimal separator is set to the .
    Control Panel, Regional Settings, Advanced, change the decimal separator to a . and apply then start Sketchup.
     
  3. leroy spronk

    Builder

    Joined:
    Jun 29, 2019
    Messages:
    2
    Likes Received:
    1
    That was the fix thank you very much
     
    David the swarfer likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice