Welcome to Our Community

Some features disabled for guests. Register Today.

Port Disconnect

Discussion in 'OpenBuilds Forum Help' started by tkbriggs, Apr 20, 2019.

  1. tkbriggs

    tkbriggs New
    Builder

    Joined:
    Apr 13, 2019
    Messages:
    4
    Likes Received:
    0
    I've been having this issue off and on lately...

    In the middle of a job, the port is dissconnecting and therefore the cutting job stops. It reads the following on the g code editor:

    [disconnect] PORT INFO: Port closed

    I flashed the software, turned off the limit switches in Grbl settings and that seemed to work for a few days. Now its having the same problem and I repeated that process and nothing... I've also turned the switches back on and off, changed the main usb cord, reset the control board / computer, updated OpenBuilds Control, used a different computer and repeated the steps above.. Tried most things now and about to start chasing wires to check all connections...

    Any help / ideas would be appreciated, thanks.
     
  2. sharmstr

    sharmstr Master
    Moderator Builder

    Joined:
    Mar 23, 2018
    Messages:
    1,006
    Likes Received:
    611
    Does your computer have any power saving feature for the usb ports enabled?
     
  3. tkbriggs

    tkbriggs New
    Builder

    Joined:
    Apr 13, 2019
    Messages:
    4
    Likes Received:
    0
    Everything is set to 2+ hrs for the computer settings, the port gets drop at random intervals.
     
  4. jeffmorris

    jeffmorris Well-Known
    Builder

    Joined:
    Nov 6, 2017
    Messages:
    284
    Likes Received:
    50
    Disable all power saving features. Go to Windows Settings, Power and Sleep, Additional Power Settings, Change Plan Settings, Change Advanced Power Settings, USB Settings, and change USB Selective Suspend Setting to Disabled
     
    Peter Van Der Walt and sharmstr like this.
  5. tkbriggs

    tkbriggs New
    Builder

    Joined:
    Apr 13, 2019
    Messages:
    4
    Likes Received:
    0
    Tried this on windows, still have the same issue... I chased / re-did all the wiring connections and switched to the macbook to run openbuilds control... still has the same issue. Just did the PRAM and SMC reset for the macbook, will see if this solves anything.
    Thanks for the help.
     
  6. tkbriggs

    tkbriggs New
    Builder

    Joined:
    Apr 13, 2019
    Messages:
    4
    Likes Received:
    0
    Still having the port disconnect.
     
  7. sharmstr

    sharmstr Master
    Moderator Builder

    Joined:
    Mar 23, 2018
    Messages:
    1,006
    Likes Received:
    611
    That sucks. Im sure when everyone is back online tomorrow, someone smarter than me will have a suggestion.
     
  8. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Builder

    Joined:
    Mar 1, 2017
    Messages:
    2,167
    Likes Received:
    1,080
    Most likely reason: EMI
    - Make sure you route USB far from any power/motor wires
    - Use quality USB cables with Ferrite Filters (Or buy some clip on ferrite cores and clip onto USB cable
    - If its a PC use the back USB ports - front ports are more susceptible to EMI due to the unshielded extensions inside the PC case sometimes used
    - Take a look at the environment where you run the machine and look for sources of electromagnetic radiation that could affect the stability of the USB connection
    - Sometimes adding a powered USB Hub between the computer and a device helps eliminate some EMI as well
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice