Welcome to Our Community

Some features disabled for guests. Register Today.

need help workbee ??

Discussion in 'General Talk' started by olivier gauthier, Apr 22, 2020.

  1. olivier gauthier

    Builder

    Joined:
    Jan 13, 2019
    Messages:
    2
    Likes Received:
    0
    hi ,i have a workbee it won't work (doesn't move ... no power) i have verified the wire ok , motor ok, arduino comunicate whit openbuild control , dr8825 power in and at the right volt. it'a 1 month that i try to make this work ... i don't know what else to try . can someone help me figure this out??
     
  2. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Project Maker Builder Resident Builder

    Joined:
    Mar 1, 2017
    Messages:
    6,204
    Likes Received:
    2,122
    - Set $4=0 (DRV8825s on a CNC Shield? They need $4=0, all our controllers use $4=1)
    - The tiny little breakout boards are a thermal nightmare, you're lucky to get 0.8-1A RMS out of a DRV8825 with those before they thermal shutdown (looks on, but isnt, or just skips a tonne of steps, or worse, dies) - and even if it works is sooo underpowered for a workbee!
    - Consider a real controller like OpenBuilds BlackBox 4X Documentation with 4A stepper drivers (3.2A RMS)
     
  3. Giarc

    Giarc OpenBuilds Team
    Staff Member Moderator Builder Resident Builder

    Joined:
    Jan 24, 2015
    Messages:
    2,075
    Likes Received:
    1,109
    I had those drv8825s with a cnc shield for starters. They were overheated way too easily. I upgraded to the DQ542MAs with my arduino before I had even completed the build and I am so glad I did. However, it is cheaper and way easier now to get the BlackBox.
     
    Peter Van Der Walt likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice