Welcome to Our Community

Some features disabled for guests. Register Today.

Need help with homing a 1010 while using limit switches

Discussion in 'Control Software' started by Eric Arnold, Jun 28, 2019.

  1. Eric Arnold

    Builder

    Joined:
    Aug 8, 2017
    Messages:
    19
    Likes Received:
    10
    Hi All,
    I'm very new to CNC and Grbl, and and trying to finalize the setup of a Workbee 1010. Limit switches are on the ends of the X, Y and Z, and all 3 switches work. The issue: the homing cycle is interrupted by the limit switches. Question - Is it possible to customize where the homing cycle ends on the X, Y and Z axes? If so, how is this accomplished?

    Here is my current Grbl settings, using the latest version of the OpenBuilds Control software.
    $1 255
    $2 0
    $3 invert X
    invert y
    invert z
    $4 enable
    $5 disable
    $6 disable
    $10 1
    $11 0.020
    $12 0.002
    $13 disable
    $20 disable
    $21 enable
    $22 enable
    $23 3
    $24 100.000
    $25 1000.000
    $26 250
    $27 3.000
    $30 1000
    $31 0
    $32 disable
    $100 199.100
    $101 199.100
    $102 199.100
    $110 2500.000
    $111 2500.000
    $112 2500.000
    $120 150.000
    $121 150.000
    $122 150.000
    $130 824.000
    $131 780.000
    $132 122.000

    Thank you so much for any help!!
     

    Attached Files:

    • 2.jpg
      2.jpg
      File size:
      93.5 KB
      Views:
      8
    • 1.jpg
      1.jpg
      File size:
      104.5 KB
      Views:
      8
    • 4.jpg
      4.jpg
      File size:
      68.8 KB
      Views:
      8
    • 3.jpg
      3.jpg
      File size:
      63.3 KB
      Views:
      10
  2. sharmstr

    sharmstr Master
    Moderator Builder

    Joined:
    Mar 23, 2018
    Messages:
    1,045
    Likes Received:
    627
    This happens for 2 reasons.

    1 - Your steps per mm aren't correct. Have you calibrated your motor steps yet? If not, run through the machine calibration in the Wizards menu.

    2 - If yes to above, then you need to increase your pulloff. That is done with $27 in the settings tab. You have it set to 3mm now, which should be enough if you're steps per mm are correct.
     
    Eric Arnold likes this.
  3. Eric Arnold

    Builder

    Joined:
    Aug 8, 2017
    Messages:
    19
    Likes Received:
    10
    Thank you Sharmstr. I will run through the machine calibration in the Wizards as soon as possible tomorrow.
     
    sharmstr likes this.
  4. Eric Arnold

    Builder

    Joined:
    Aug 8, 2017
    Messages:
    19
    Likes Received:
    10
    The homing cycle works now. I didn't really do anything other than complete the x-y-z calibration in the Wizards and & Tools (didn't need to change any mm values). Perhaps completing the calibration was a step that I missed somewhere. Thanks again... moving on to installing a z touch plate now...
     
    sharmstr likes this.
  5. sharmstr

    sharmstr Master
    Moderator Builder

    Joined:
    Mar 23, 2018
    Messages:
    1,045
    Likes Received:
    627
    Excellent. Hard to tell if you understand why that made it work, so I'll explain. If your machine isnt calibrated, then when grbl was telling it to move 3mm off the switch, it was moving less than that. Now that you are calibrated, its moving 3mm which is enough distance to untrigger the limit switch.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice