Welcome to Our Community

Some features disabled for guests. Register Today.

First Question from this Newbie...

Discussion in 'General Talk' started by ClaudeJER, Dec 24, 2018.

  1. ClaudeJER

    ClaudeJER Well-Known
    Builder

    Joined:
    Oct 2, 2018
    Messages:
    26
    Likes Received:
    14
    Hi guys, I'm new here so please bear with me for some maybe very basic questions??
    I just finished building my Lead machine which came with the SparkConcept xpro V3 controller.
    The machine seems to work well with the "Hello World" sample gcode available on here but when I try to upload gcode generated by Solidworks, I tried many different format, .cnc,.tap, .nc nothing works and I sometime get a code error right from the first gcode line.
    Is there a secret sauce I don't know about???
    What gcode format should I export from Solidworks that works well with this controller.
    Thanks and Merry Christmas.
    Claude
     
    #1 ClaudeJER, Dec 24, 2018
    Last edited: Dec 24, 2018
  2. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Builder

    Joined:
    Mar 1, 2017
    Messages:
    1,263
    Likes Received:
    685
    The Xpro runs GRBL Firmware. Your CAM needs to have a post processor that outputs GRBL compatible gcode. Not all GCODE is equal, different systems have minor differences in the dialect, from including/excluding specific commands, even down to how many decimals to round to. Checkout gnea/grbl and gnea/grbl for some details

    To solve the problem, google around for a "Grbl compatible post processor for solidworks".
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice