Welcome to Our Community

Some features disabled for guests. Register Today.

CNC xPRO V4 Controller Wiring incorrect

Discussion in 'OpenBuilds Bug Report' started by Bob Waterfield, Jan 25, 2019.

  1. Bob Waterfield

    Bob Waterfield Well-Known
    Builder

    Joined:
    Jan 21, 2019
    Messages:
    21
    Likes Received:
    3
    According to the wiring diagram supplied with the board, the second Y axis motor no longer needs the wires reversed. This is NOT true.
    Still had to reverse the wire pair on my board for the motor wired into the A port (Y2).
    Please correct.
     
  2. Rick 2.0

    Rick 2.0 OpenBuilds Team
    Staff Member Moderator Resident Builder Builder

    Joined:
    Dec 20, 2013
    Messages:
    2,021
    Likes Received:
    928
    Whether or not to reverse a wire pair is contingent on the style machine built. For belted systems one pair on one motor must be reversed, for screw driven systems both motors should be wired the same.
     
    Peter Van Der Walt and MaryD like this.
  3. Bob Waterfield

    Bob Waterfield Well-Known
    Builder

    Joined:
    Jan 21, 2019
    Messages:
    21
    Likes Received:
    3
    Rick,
    I agree, but the card supplied with the board clearly shows all 4 stepper motors wired the same. The card came with the board from Spark Concepts.
    Just an FYI.
     
  4. Rick 2.0

    Rick 2.0 OpenBuilds Team
    Staff Member Moderator Resident Builder Builder

    Joined:
    Dec 20, 2013
    Messages:
    2,021
    Likes Received:
    928
    Problem is, you're preaching to the choir here. If you want to get @Spark Concepts attention over this you'd be better off posting on their thread CNC xPRO V4.
     
  5. Bob Waterfield

    Bob Waterfield Well-Known
    Builder

    Joined:
    Jan 21, 2019
    Messages:
    21
    Likes Received:
    3
    Rick...
    I understand that, sent them an email this morning.
     
  6. Spark Concepts

    Spark Concepts Veteran
    Builder

    Joined:
    Dec 17, 2013
    Messages:
    126
    Likes Received:
    87
    Hi Bob,

    As Rick mentioned the motor wiring will be dependent on the style of build - as most build have gone to a Workbee/Lead setup the motor wires do not need to be swapped so that is shown on the start card. I can see how that would be a bit confusing if you are building an Ox. I appreciate the feedback and will see what changes we can squeeze on the card to indicate this.

    Thanks,
    Mike
     
  7. Bob Waterfield

    Bob Waterfield Well-Known
    Builder

    Joined:
    Jan 21, 2019
    Messages:
    21
    Likes Received:
    3
    Maybe just a side note next to the "A" motor connection to reverse on belt driven units.
    Glad I tested with the belts removed the first time
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice