Welcome to Our Community

Some features disabled for guests. Register Today.

blackbox remove z axis homing

Discussion in 'Controller Boards' started by sitoru, Apr 16, 2019.

  1. sitoru

    sitoru Well-Known
    Builder

    Joined:
    Aug 13, 2014
    Messages:
    13
    Likes Received:
    2
    Im using blackbox to control my laser, but have no z axis. I would like to start using homing for x and y, so I know I have to recompile Grbl to remove z homing. Is your version of Grbl for blackbox different than the regular Grbl? would it be ok to use that? or do you have a blackbox version without z homing available ?
     
  2. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Builder

    Joined:
    Mar 1, 2017
    Messages:
    1,394
    Likes Received:
    740
    OpenBuilds Control -> Troubleshooting Tab > Grbl Flashing -> Flash Grbl 1.1g for ACRO (Acro is a 2 axis machine, so has Zhoming disabled as per gnea/grbl (already applied, compiled and available to you in CONTROL with no schelp)

    Apart from that easy way if you really want to compile, stock default works. Just set $4=1 (inverted driver enable)
     
  3. sitoru

    sitoru Well-Known
    Builder

    Joined:
    Aug 13, 2014
    Messages:
    13
    Likes Received:
    2
    ok, thanks I'll try that.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice