Welcome to Our Community

Some features disabled for guests. Register Today.

BlackBox Limit Switch Search time out issue!

Discussion in 'Controller Boards' started by thatguypeter, Apr 26, 2019.

  1. thatguypeter

    thatguypeter Journeyman
    Builder

    Joined:
    Jan 28, 2019
    Messages:
    37
    Likes Received:
    11
    OK..back again,

    I just got the new BlackBox second batch and got it running. I got new issuer now with the search limit time out issue. Please see the attached image. How do I make the search goes longer? It work great when the X and Y are closed to the limit switches, but if they are really far away it would time out on the homing sequences.

    The old box didn't got this issue..it Home fine with the same setting...I just switch out the old box and put in the new one.

    Peter
     

    Attached Files:

  2. Peter Van Der Walt

    Peter Van Der Walt OpenBuilds Team
    Staff Member Moderator Resident Builder Project Maker Builder

    Joined:
    Mar 1, 2017
    Messages:
    1,073
    Likes Received:
    616
    Ensure your steps per mm are correct, else what you tell it to do in step 2 wont match what happens in reality

    For the Homing Pull-off Error (Coming out of the switch after homing, doesnt "release" the switch)
    > Set Homing Pulloff $27 to 10mm: gnea/grbl (default is 5, depending on how you mount a lever-style switch 5mm may not be enough to clear out of the switch)

    For the Could not find limit with Search Distance:
    > Make sure your Machine Size is correctly defined: gnea/grbl - it will only go those distances *1.5 maximum
     
  3. thatguypeter

    thatguypeter Journeyman
    Builder

    Joined:
    Jan 28, 2019
    Messages:
    37
    Likes Received:
    11
    Hey Peter,

    This happen after I did the calibration for the steps..it was really out of wack..the 100mm test were all wrong for the each axis. After the correction it no longer home right and I get these issues. I have a GT2 Belt with 20Tooth, 1.8 degree pitch and NEMA 21 motor..the calculation gave me 40MM steps. I made the adjustment and everything tested out correctly and accurate now. I just can't get it to home right..is there a way to make the search time longer??

    Peter
     

    Attached Files:

  4. sharmstr

    sharmstr Master
    Moderator Builder

    Joined:
    Mar 23, 2018
    Messages:
    566
    Likes Received:
    317
    Can you tell us what value you have set in

    $130 (x-axis maximum travel)
    $131 (y-axis maximum travel)
    $132 (z-axis maximum travel).

    I see you have the C-beam xl machine config loaded so it defaults to 200mm which if I understand correctly will only travel 300mm when homing. If your machine is larger, than you need to change those values.

    Edit: For what its worth, I have the workbee 1510 and have no issue homing from 1400mm away from the switch. So I think the above might be your issue. Fingers crossed :)
     
  5. thatguypeter

    thatguypeter Journeyman
    Builder

    Joined:
    Jan 28, 2019
    Messages:
    37
    Likes Received:
    11
    I got a table that 115" Y Axis and 1500MM C beam for the X Axis...250mm for the Z Axis...I called the Rhino! It can cut 4' x 8' plywood..
     

    Attached Files:

    MaryD likes this.
  6. sharmstr

    sharmstr Master
    Moderator Builder

    Joined:
    Mar 23, 2018
    Messages:
    566
    Likes Received:
    317
    That's the problem then. You need to set those correctly or its only going to move 300mm before homing times out.

    Peter indicated that above, but I think you missed it.

    Edit: Nice machine by the way!
     
    #6 sharmstr, Apr 29, 2019
    Last edited: Apr 29, 2019
    thatguypeter likes this.
  7. thatguypeter

    thatguypeter Journeyman
    Builder

    Joined:
    Jan 28, 2019
    Messages:
    37
    Likes Received:
    11
    Thank you....Thank you!! You guys rock...I got it to work now by changing the 130 to 132 size of my table!!! I will be send the old box back today..Thank you for all the help!!!

    Peter
     
    sharmstr likes this.
  8. sharmstr

    sharmstr Master
    Moderator Builder

    Joined:
    Mar 23, 2018
    Messages:
    566
    Likes Received:
    317
    All credit goes to Peter. I wouldnt have even known to check that if he hadn't mentioned it above. Anyhow, glad you are sorted. If you have the time, it would be cool if you posted your machine in the builds section. Would love to learn more about it.
     
    Peter Van Der Walt likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice